Page 1 of 1

From Table queries not refreshing

Posted: Mon Dec 02, 2019 5:08 pm
by ierosadopr
Ok so this is super weird.

First, when I add a query "from table", even if the table has only a few rows and columns (ie. 3 and to respectively) the refresh icon never stops turning. (see attached a picture of what I'm referring to)

Moreover, as I try to add these to a excel sheet's data model, the data model (table and diagram views) nevertheless appears "empty". (this happens in blank excel workbooks too, leading me to believe its a bug in my excel version [see below for details])

The workaround to this was the following: I use the "relationships" button in excel and established dummy relations between these tables. Hence, I could now see these in the data model.

However, these tables never stop refreshing. I went to the privacy settings and clicked on "ignore" every possible privacy option.. but it still doesn't work.

Worth to mention, queries to external sources like APIs do work on my excel. Very frustrating.

My excel version is the following:
Microsoft Excel 2016 MSO (16.0.12130.20232) 32-bit
Version 1910 (Build 12130.20410 Click-to-Run)

please help

Re: From Table queries not refreshing

Posted: Mon Dec 02, 2019 5:10 pm
by ierosadopr
clarification: the relationship button within: Data tab -> Data tools

Re: From Table queries not refreshing

Posted: Mon Dec 02, 2019 5:19 pm
by ierosadopr
Also, one last piece of information (sorry) I get this message on all the from-table queries: "There are no connections for this query". see attached.

Re: From Table queries not refreshing  [Solved]

Posted: Fri Dec 13, 2019 12:53 am
by ierosadopr
Bought Office 365. Issue solved.