From Table queries not refreshing

Any topic that doesn't fit in elsewhere
ierosadopr
Posts: 4
Joined: Mon Sep 02, 2019 11:29 pm

From Table queries not refreshing

Postby ierosadopr » Mon Dec 02, 2019 5:08 pm

Ok so this is super weird.

First, when I add a query "from table", even if the table has only a few rows and columns (ie. 3 and to respectively) the refresh icon never stops turning. (see attached a picture of what I'm referring to)

Moreover, as I try to add these to a excel sheet's data model, the data model (table and diagram views) nevertheless appears "empty". (this happens in blank excel workbooks too, leading me to believe its a bug in my excel version [see below for details])

The workaround to this was the following: I use the "relationships" button in excel and established dummy relations between these tables. Hence, I could now see these in the data model.

However, these tables never stop refreshing. I went to the privacy settings and clicked on "ignore" every possible privacy option.. but it still doesn't work.

Worth to mention, queries to external sources like APIs do work on my excel. Very frustrating.

My excel version is the following:
Microsoft Excel 2016 MSO (16.0.12130.20232) 32-bit
Version 1910 (Build 12130.20410 Click-to-Run)

please help
Attachments
Capture.PNG
Capture.PNG (15.58 KiB) Viewed 363 times

ierosadopr
Posts: 4
Joined: Mon Sep 02, 2019 11:29 pm

Re: From Table queries not refreshing

Postby ierosadopr » Mon Dec 02, 2019 5:10 pm

clarification: the relationship button within: Data tab -> Data tools

ierosadopr
Posts: 4
Joined: Mon Sep 02, 2019 11:29 pm

Re: From Table queries not refreshing

Postby ierosadopr » Mon Dec 02, 2019 5:19 pm

Also, one last piece of information (sorry) I get this message on all the from-table queries: "There are no connections for this query". see attached.
Attachments
Capture2.PNG
Capture2.PNG (72.45 KiB) Viewed 359 times


Return to “General”

Who is online

Users browsing this forum: No registered users and 0 guests

cron